Modify

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#267 closed defect (worksforme)

'Formatter' object has no attribute 'args'

Reported by: anonymous Owned by: moschny
Priority: normal Milestone:
Component: trac.tracnav Version:
Severity: normal Keywords:
Cc:

Description

If i include TracNav to my Trac i get this error:

'Formatter' object has no attribute 'args'

I using trac 0.11dev. I included TracNav at the Page "Team" with:

[[TracNav(Team/Menu)]]

Attachments (0)

Change History (10)

comment:1 Changed 11 years ago by kovid@…

This happened for me when upgrading trac from r4386 to r4507.

comment:2 Changed 11 years ago by anonymous

So it looks like a bug of trac svn version?

comment:3 Changed 11 years ago by moschny

  • Status changed from new to assigned

Hmm, rather an API change, but I'll have to look at it closer. Patches are welcome, btw. :)

comment:4 Changed 11 years ago by moschny

Fix is almost there, needs some testing. Be patient!

comment:5 Changed 11 years ago by moschny

Should be fixed in [3145].

comment:6 Changed 11 years ago by kovid@…

Confirmed. Works for me.

comment:7 Changed 11 years ago by moschny

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:8 Changed 11 years ago by bobbens

  • Resolution fixed deleted
  • Status changed from closed to reopened

I've recently upgraded trac to svn r4612 and tracnav to svn r3156 and I seem to get the same problem:

Error: Macro TracNav() failed

'Formatter' object has no attribute 'args'

It seems like something changed again.

comment:9 Changed 11 years ago by moschny

  • Resolution set to worksforme
  • Status changed from reopened to closed

Just tested here locally: The plugin works fine with Trac 4612. Be sure to use the devel version of TracNav (see TracNav/DownloadAndInstall).

comment:10 Changed 11 years ago by bobbens

ah, wasn't using the devel version. Most trac plugins just add a 0.11 directory in the trunk/ folder. I was just doing "svn upgrade" on the old svn directory. It works fine now.

Add Comment

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain moschny.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.