Opened 4 years ago

Closed 4 years ago

#38 closed task (fixed)

admintool ssl problem with new java runtime

Reported by: lama Owned by:
Priority: nextThingToDo Component: jplagAdminTool
Keywords: Cc:

Description

java.lang.ExceptionInInitializerError
	at com.sun.deploy.net.protocol.https.Handler.openConnection(Handler.java:97)
	at java.net.URL.openConnection(URL.java:969)
	at com.sun.deploy.net.BasicHttpRequest.createUrlConnection(BasicHttpRequest.java:273)
	at com.sun.deploy.net.BasicHttpRequest.doRequest(BasicHttpRequest.java:149)
	at com.sun.deploy.net.BasicHttpRequest.doGetRequestEX(BasicHttpRequest.java:63)
	at com.sun.deploy.net.DownloadEngine.actionDownload(DownloadEngine.java:1153)
	at com.sun.deploy.net.DownloadEngine.getCacheEntry(DownloadEngine.java:1528)
	at com.sun.deploy.net.DownloadEngine.getCacheEntry(DownloadEngine.java:1506)
	at com.sun.deploy.net.DownloadEngine.getResourceCacheEntry(DownloadEngine.java:1609)
	at com.sun.deploy.net.DownloadEngine.getResourceCacheEntry(DownloadEngine.java:1537)
	at com.sun.deploy.net.DownloadEngine.getResource(DownloadEngine.java:217)
	at com.sun.deploy.net.DownloadEngine.getResource(DownloadEngine.java:201)
	at com.sun.javaws.Launcher.updateFinalLaunchDesc(Launcher.java:468)
	at com.sun.javaws.Launcher.prepareToLaunch(Launcher.java:248)
	at com.sun.javaws.Launcher.prepareToLaunch(Launcher.java:199)
	at com.sun.javaws.Launcher.launch(Launcher.java:116)
	at com.sun.javaws.Main.launchApp(Main.java:412)
	at com.sun.javaws.Main.continueInSecureThread(Main.java:249)
	at com.sun.javaws.Main$1.run(Main.java:111)
	at java.lang.Thread.run(Thread.java:722)
Caused by: java.lang.ClassCastException: sun.security.ssl.X509TrustManagerImpl cannot be cast to com.sun.net.ssl.internal.ssl.X509ExtendedTrustManager
	at com.sun.deploy.security.X509ExtendedDeployTrustManager.<init>(X509ExtendedDeployTrustManager.java:113)
	at com.sun.deploy.net.protocol.https.Handler$Initializer$1.run(Handler.java:70)
	at java.security.AccessController.doPrivileged(Native Method)
	at com.sun.deploy.net.protocol.https.Handler$Initializer.<clinit>(Handler.java:40)
	... 20 more

Change History (1)

comment:1 Changed 4 years ago by lama

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.